Document Search Delays

Incident Report for Babel Street Insights

Resolved

This incident has been resolved.
Posted Jul 28, 2026 - 15:27 UTC

Monitoring

The situation has stabilized and current content is now caught up in Document Search. We will continue to monitor for any further issues.
Posted Jul 24, 2026 - 22:45 UTC

Identified

We've identified an issue that is causing significant delays with new content appearing in all document related searches. Our development teams are actively working on a resolution.
Posted Jul 24, 2026 - 20:39 UTC
This incident affected: Documents.