Insights Outage

Incident Report for Babel Street Insights

Resolved

This incident has been resolved.
Posted Feb 04, 2026 - 14:28 UTC

Update

We are continuing to investigate this issue.
Posted Feb 04, 2026 - 13:18 UTC

Investigating

We’re experiencing an outage affecting Insights. Our team is investigating and we’ll provide an update soon.
Posted Feb 04, 2026 - 13:17 UTC
This incident affected: Documents, Logins and Alerting, People, Projects, Business, Images, and Domains.