Document Search Delays

Incident Report for Babel Street Insights

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 20:32 UTC

Monitoring

We apologize for the incorrect update. There has been an issue identified with a delay of documents populating in Document Search. Development teams are nearing a resolution and we are awaiting confirmation.
Posted Jul 24, 2026 - 20:16 UTC

Identified

We have identified an ongoing issue where errors are returning in Investigator. The error appears when starting a new thread and when replying in a saved thread. Our development teams are actively working on a resolution.
Posted Jul 24, 2026 - 20:02 UTC
This incident affected: Documents.