Issues with Retrieve Documents in People Search

Incident Report for Babel Street Insights

Resolved

Quick update on the People Search issue — this has now been resolved. The root cause turned out to be a permissions issue, which has been corrected. Everything is functioning as expected now.
Posted May 28, 2026 - 14:06 UTC

Identified

Retrieve Documents functionality within People Search is currently experiencing an outage. The team is actively investigating the issue and working toward a resolution. We’ll provide additional updates as more information becomes available.
Posted May 26, 2026 - 15:25 UTC
This incident affected: People.