Search and Related Features Impacted

Incident Report for Babel Street Insights

Resolved

This incident has been resolved.
Posted Feb 11, 2026 - 19:50 UTC

Monitoring

Services are beginning to come back online. We are seeing recovery across People and Business Search, as well as related features including Projects, Saved Searches, and Bookmarks. We are continuing to monitor closely to ensure full stability and will provide confirmation once the incident is fully resolved.
Posted Feb 11, 2026 - 19:22 UTC

Identified

Search and Business Search are currently down.
The team is actively working on a fix and we will share further updates as they become available.
Posted Feb 11, 2026 - 18:37 UTC
This incident affected: People, Projects, and Business.