Insights Outage

Incident Report for Babel Street Insights

Resolved

Insights has been fully restored. The issue was caused by an AWS service disruption, which has now been resolved. We’re monitoring closely to ensure continued stability. Thanks for your patience.
Posted Feb 04, 2026 - 20:32 UTC

Update

The team has implemented a fix, and we should now be seeing improved performance. We’ll continue to monitor closely to ensure stability. Thank you for your patience.
Posted Feb 04, 2026 - 16:48 UTC

Update

We’re continuing to work on the performance issues impacting the service. Our investigation has traced the root cause to an ongoing AWS issue. We’re actively monitoring the situation and will provide another update as more information becomes available. Thank you for your patience.
Posted Feb 04, 2026 - 16:23 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 04, 2026 - 14:53 UTC
This incident affected: Documents, Logins and Alerting, People, Projects, Business, Images, and Domains.