Incorrect Document Counts and Delayed/Empty Results

Incident Report for Babel Street Insights

Resolved

The issue causing delays in document processing has been resolved. Processing has fully caught up, and the system is operating normally.

Our team has verified that documents are being ingested and returned as expected.

Thank you for your patience while we worked through this issue. If you continue to experience any unexpected behavior, please contact Support.
Posted Jun 10, 2026 - 13:57 UTC

Identified

We are currently investigating an issue where some saved filters in Insights may display document counts that do not match the number of documents available when the filter is opened. In some cases, users may also experience delayed or empty results when accessing those filters.

Our team is actively reviewing the issue and working to restore accurate document counts and expected filter behavior. We will provide an update as soon as more information is available.
Posted Jun 08, 2026 - 19:16 UTC
This incident affected: Documents.