Insights Investigator Outage

Incident Report for Babel Street Insights

Resolved

The issue causing errors with Investigator has been identified and resolved.
Posted Jul 24, 2026 - 18:57 UTC

Investigating

Investigator is currently experiencing errors when attempting to start a new thread or respond in an existing thread. We are actively investigating for a root cause and resolution.
Posted Jul 24, 2026 - 16:12 UTC
This incident affected: Documents.