Decline in Babel Data Library collection

Incident Report for Babel Street Insights

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 19:09 UTC

Monitoring

Our team has completed the initial investigation and identified the area requiring changes. We are currently implementing and validating the solution to ensure it addresses the reported behavior without impacting related functionality.

Current status:
• Investigation completed.
• Root cause identified.
• Solution implementation is in progress.
• Validation and testing are underway.

Expected timeline:
• We anticipate completing the remaining work and providing a further update within the next 2 hours.
Posted Jun 04, 2026 - 15:56 UTC

Identified

We are currently investigating the issue and have identified a problem on our side that is affecting collection performance. Our team is actively working to resolve it and restore normal collection levels as quickly as possible.

We will keep you updated as we make progress and will let you know as soon as the issue has been resolved.

We appreciate your patience and apologize for the inconvenience.
Posted Jun 03, 2026 - 14:24 UTC
This incident affected: Documents.